Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
lens problem: weird acquired vignetting
#1
On my Tokina 16-28 I noticed a triangular edge vignetting that did not exist before

it's only at 16mm, already visible in the EVF and disappears when zooming

What do you think is the problem??

guy at repairs says he has never seen something similar and is reluctant to open the lens, anybody has an idea what's the problem ?

[Image: attachment.php?aid=131]


Attached Files
.jpg   faloughasaydi2019_0372.jpg (Size: 309.5 KB / Downloads: 58)
#2
Which camera, JPEG or RAW? Not "triangles", clearly a circle. Turn off peripheral illumination correction on your RP.
#3
(03-13-2021, 06:09 AM)Brightcolours Wrote: Which camera, JPEG or RAW? Not "triangles", clearly a circle. Turn off peripheral illumination correction on your RP.

I checked both on RP and on 6D, the effect is here, and only at 16mm, rotate the zoom ring slightly and it magically disappears suddenly.
The lens was functioning normally, the same day I took photos at 16mm that were normal, I swapped for 24-105 took some photos then came back and as soon as I put it on the camera,  in the viewfinder I noticed this effect at 16mm (did the lens fall to the ground while I was busy shooting?), it is stable at all apertures doesn't change.
#4
Turn off the illumination correction on your RP. The lens is fine... Just Canon's firmware messing up. The 6D you mention probably is a 6D mark II?

Dave, it is the same issue often reported with particular Sigma lenses on Canon cameras. Illumination correction going haywire with lenses the camera "misunderstands". Nothing in the lens is wrong or "going on".
https://www.slrlounge.com/sigma-issues-l...s-cameras/
https://www.imaging-resource.com/news/20...es-but-why

If you look at the bottom right corner, you can actually see a lighter circle on the inner edge the dark corner circle.
Same as here:

.jpg   rptokina.jpg (Size: 389.03 KB / Downloads: 2)
Same lens (Tokina 16-28mm), same setting (16mm), same camera (RP), same issue (illumination correction turned on).
#5
Also visible in the EVF ??  ....... when taking the image ..... or when reviewing it !!

Presumably when reviewing it .... it was the seeing it in the EVF which seemed especially weird ........ third party lens's incomplete compatibility ........
Dave's clichés
#6
Brightcolours nailed it.
Peripheral Illumination Correction is Canon-speak for in-camera vignetting correction. This works *only* with Canon glass, because in order for it to work the camera must have the correct parameters for the lens in use, and Canon doesn't know about third-party glass.

This is an issue also with older Canon bodies, even my 50D gets confused when I use my Sigma 10-20 with vignetting correction active. I just leave the vignetting correction turned off and apply it in post when needed: RawTherapee has vignetting and distortion correction for most current lenses.

The RP, like other R-series cameras, applies vignetting correction in the viewfinder too, so when you use third party glass with vignetting correction active you get the same artifacts in the EVF as you get in the OOC jpegs.
  


Forum Jump:


Users browsing this thread:
2 Guest(s)